Back to overview
Downtime

Incident with our hosting provider

Apr 9, 2026 at 12:28pm UTC
Affected services
API Services
Main web application
Load balancer

Resolved
Apr 9, 2026 at 1:00pm UTC

Everything seems to be back in order and working fine again.
Thank you for your patience.

Updated
Apr 9, 2026 at 12:50pm UTC

C2E Market should be online right now.
We are still waiting for a complete report from our hosting provider, and we're monitoring the situation closely.

Created
Apr 9, 2026 at 12:28pm UTC

There seems to be an incident with our hosting provider, our platform is offline for now.
We are investigating the issue and will keep you updated.